安装互为依赖关系的rpm包

当你在linux下,
分别安装
rpm -ivh elfutils-libelf-devel-0.137-3.el5.i386.rpm
rpm -ivh elfutils-libelf-devel-static-0.137-3.el5.i386.rpm
时,你会从错误信息中发现,两个包互为依赖,需要先安装对方包,才能安装!

解决办法
1、两个包一起安装
rpm -ivh elfutils-libelf-devel-0.137-3.el5.i386.rpm elfutils-libelf-devel-static-0.137-3.el5.i386.rpm
2、构建yum库,使用yum方式安装
yum install elfutils-libelf-devel*

You may also like...

发表评论